debian/patches/0001-reproductible-build.patch: Try harder to make the doc reproductible

This commit is contained in:
Laurent Bigonville 2019-08-01 20:51:27 +02:00
parent ed73672c7c
commit e15be88231

View File

@ -15,3 +15,27 @@ Last-Update: 2019-07-28
--xsltproc-opts "--stringparam nut.nutversion \"@PACKAGE_VERSION@\"" \
--attribute iconsdir=$(srcdir)/images \
--attribute=badges \
--- a/configure.ac
+++ b/configure.ac
@@ -1211,7 +1211,7 @@ LIBDIR=${conftemp}
AC_DEFINE_UNQUOTED(LIBDIR, "${conftemp}", [Default path for system libraries])
dnl Current date
-now=`TZ=UTC date +%Y-%m-%d`
+now=`TZ=UTC date +%Y-%m-%d -d @${SOURCE_DATE_EPOCH}`
AC_SUBST(now)
AC_SUBST(OS_NAME)
--- a/docs/man/Makefile.am
+++ b/docs/man/Makefile.am
@@ -591,8 +591,8 @@ if HAVE_ASCIIDOC
.txt.html:
$(ASCIIDOC) --backend=xhtml11 \
- --attribute localdate=`TZ=UTC date +%Y-%m-%d` \
- --attribute localtime=`TZ=UTC date +%H:%M:%S` \
+ --attribute localdate=`TZ=UTC date +%Y-%m-%d -d @$(SOURCE_DATE_EPOCH)` \
+ --attribute localtime=`TZ=UTC date +%H:%M:%S -d @$(SOURCE_DATE_EPOCH)` \
--attribute nutversion="@PACKAGE_VERSION@" \
-o $@ $<