New upstream release (Closes: #575176, #609597)

* New upstream release (Closes: #575176, #609597)
* debian/patches/*.patch: removed since these are now fixed upstream
* debian/patches/0001-fix_spelling_and_typo.patch,
  debian/patches/series: reworked to match the new upstream release
* debian/nut.install, debian/nut.manpages: remove obsolete reference to
  megatec and megatec_usb, now repectively replaced by blazer_ser and
  blazer_usb
This commit is contained in:
Arnaud Quette 2011-02-02 17:51:42 +01:00
parent 405017598b
commit 9584e8dd52
8 changed files with 262 additions and 318 deletions

11
debian/changelog vendored
View File

@ -1,3 +1,14 @@
nut (2.6.0-1) UNRELEASED; urgency=low
* New upstream release (Closes: #575176, #609597)
* debian/patches/*.patch, debian/patches/series: removed since these
are now fixed upstream
* debian/nut.install, debian/nut.manpages: remove obsolete reference to
megatec and megatec_usb, now repectively replaced by blazer_ser and
blazer_usb
-- Arnaud Quette <aquette@debian.org> Fri, 28 Jan 2011 11:08:10 +0100
nut (2.4.3-3) UNRELEASED; urgency=low
* debian/control:

2
debian/nut.install vendored
View File

@ -49,8 +49,6 @@ debian/tmp/lib/nut/bcmxcp_usb
debian/tmp/lib/nut/victronups
debian/tmp/lib/nut/tripplitesu
debian/tmp/lib/nut/optiups
debian/tmp/lib/nut/megatec_usb
debian/tmp/lib/nut/upsdrvctl /sbin
debian/tmp/lib/nut/megatec
debian/tmp/lib/nut/everups
debian/tmp/lib/nut/dummy-ups

2
debian/nut.manpages vendored
View File

@ -23,8 +23,6 @@ debian/tmp/usr/share/man/man8/genericups.8
debian/tmp/usr/share/man/man8/isbmex.8
debian/tmp/usr/share/man/man8/liebert.8
debian/tmp/usr/share/man/man8/masterguard.8
debian/tmp/usr/share/man/man8/megatec.8
debian/tmp/usr/share/man/man8/megatec_usb.8
debian/tmp/usr/share/man/man8/metasys.8
debian/tmp/usr/share/man/man8/mge-shut.8
debian/tmp/usr/share/man/man8/mge-utalk.8

View File

@ -0,0 +1,250 @@
--- a/docs/man/dummy-ups.txt (revision 2722)
+++ b/docs/man/dummy-ups.txt (revision 2882)
@@ -56,5 +56,5 @@
This file is generally named "something.dev". It contains a list of all
valid data and associated values, and has the same format as an linkman:upsc[8]
-dump (<varname>: <value>). So you can easilly create definition
+dump (<varname>: <value>). So you can easily create definition
files from an existing UPS using "upsc > file.dev".
It can also be empty, in which case only a basic set of data is available:
--- a/docs/man/metasys.txt (revision 2722)
+++ b/docs/man/metasys.txt (revision 2882)
@@ -45,5 +45,5 @@
ally HF 1000 only.
-Any informations about the use of the driver with the other listed
+Any information about the use of the driver with the other listed
UPS are really welcome.
--- a/drivers/apcsmart.c (revision 2596)
+++ b/drivers/apcsmart.c (revision 2882)
@@ -325,5 +325,5 @@
this if the REQ_CAPABILITIES command is supported
*/
- upslogx(LOG_ERR, "ERROR: APC cannot do capabilites but said it could!");
+ upslogx(LOG_ERR, "ERROR: APC cannot do capabilities but said it could!");
return;
}
--- a/drivers/dummy-ups.c (revision 2699)
+++ b/drivers/dummy-ups.c (revision 2882)
@@ -376,5 +376,5 @@
* the update / sync process (with cmdvartab?!) */
- upsdebugx(1, "Unknown data. Commiting anyway...");
+ upsdebugx(1, "Unknown data. Committing anyway...");
return 1;
/* return 0;*/
@@ -396,5 +396,5 @@
* the update / sync process (with cmdvartab?) */
- upsdebugx(1, "Unknown data. Commiting value anyway...");
+ upsdebugx(1, "Unknown data. Committing value anyway...");
return 1;
/* return 0;*/
--- a/drivers/snmp-ups.c (revision 2757)
+++ b/drivers/snmp-ups.c (revision 2882)
@@ -485,5 +485,5 @@
break;
default:
- upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x recieved from %s",
+ upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x received from %s",
upsname?upsname:device_name, pdu->variables->type, OID);
return FALSE;
@@ -525,5 +525,5 @@
break;
default:
- upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x recieved from %s",
+ upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x received from %s",
upsname?upsname:device_name, pdu->variables->type, OID);
return FALSE;
@@ -1460,5 +1460,5 @@
upslogx(LOG_ERR, "su_setvar: cannot set value %s for %s", arg[4], arg[3]);
else
- upsdebugx(1, "su_setvar: sucessfully set %s to \"%s\"", arg[0], arg[4]);
+ upsdebugx(1, "su_setvar: successfully set %s to \"%s\"", arg[0], arg[4]);
return 1;
--- a/drivers/genericups.c (revision 2336)
+++ b/drivers/genericups.c (revision 2882)
@@ -143,10 +143,10 @@
if ((v = getval("OL")) != NULL) {
parse_input_signals(v, &upstab[upstype].line_ol, &upstab[upstype].val_ol);
- upsdebugx(2, "parse_input_signals: OL overriden with %s\n", v);
+ upsdebugx(2, "parse_input_signals: OL overridden with %s\n", v);
}
if ((v = getval("LB")) != NULL) {
parse_input_signals(v, &upstab[upstype].line_bl, &upstab[upstype].val_bl);
- upsdebugx(2, "parse_input_signals: LB overriden with %s\n", v);
+ upsdebugx(2, "parse_input_signals: LB overridden with %s\n", v);
}
}
@@ -319,10 +319,10 @@
if ((v = getval("CP")) != NULL) {
parse_output_signals(v, &upstab[upstype].line_norm);
- upsdebugx(2, "parse_output_signals: CP overriden with %s\n", v);
+ upsdebugx(2, "parse_output_signals: CP overridden with %s\n", v);
}
if ((v = getval("SD")) != NULL) {
parse_output_signals(v, &upstab[upstype].line_sd);
- upsdebugx(2, "parse_output_signals: SD overriden with %s\n", v);
+ upsdebugx(2, "parse_output_signals: SD overridden with %s\n", v);
}
--- a/drivers/metasys.c (revision 2601)
+++ b/drivers/metasys.c (revision 2882)
@@ -63,10 +63,10 @@
/*
Metasystem UPS data transfer are made with packet of the format:
- STX DATA_LENGHT DATA CHECKSUM
+ STX DATA_LENGTH DATA CHECKSUM
where:
STX is 0x02 and is the start of transmission byte
- DATA_LENGHT is number of data bytes + the checksum byte
+ DATA_LENGTH is number of data bytes + the checksum byte
DATA ......
- CHECKSUM is the sum modulus 256 of all DATA bytes + DATA_LENGHT
+ CHECKSUM is the sum modulus 256 of all DATA bytes + DATA_LENGTH
The answer from the UPS have the same packet format and the first
@@ -115,5 +115,5 @@
/* send a read command to the UPS, it retries 5 times before give up
- it's a 4 byte request (STX, LENGHT, COMMAND and CHECKSUM) */
+ it's a 4 byte request (STX, LENGTH, COMMAND and CHECKSUM) */
void send_read_command(char command) {
int retry, sent;
@@ -123,7 +123,7 @@
while ((sent != 4) && (retry < 5)) {
buf[0]=0x02; /* STX Start of Transmission */
- buf[1]=0x02; /* data lenght(data + checksum byte) */
+ buf[1]=0x02; /* data length(data + checksum byte) */
buf[2]=command; /* command to send */
- buf[3]=buf[1] + buf[2]; /* checksum (sum modulus 256 of data bytes + lenght) */
+ buf[3]=buf[1] + buf[2]; /* checksum (sum modulus 256 of data bytes + length) */
if (retry == 4) send_zeros(); /* last retry is preceded by a serial reset...*/
sent = ser_send_buf(upsfd, buf, 4);
@@ -135,5 +135,5 @@
with a char* buffer
it retries 5 times before give up */
-void send_write_command(unsigned char *command, int command_lenght) {
+void send_write_command(unsigned char *command, int command_length) {
int i, retry, sent, checksum;
unsigned char raw_buf[255];
@@ -141,21 +141,21 @@
/* prepares the raw data */
raw_buf[0] = 0x02; /* STX byte */
- raw_buf[1] = (unsigned char)(command_lenght + 1); /* data lenght + checksum */
- memcpy(raw_buf+2, command, command_lenght);
- command_lenght += 2;
+ raw_buf[1] = (unsigned char)(command_length + 1); /* data length + checksum */
+ memcpy(raw_buf+2, command, command_length);
+ command_length += 2;
/* calculate checksum */
checksum = 0;
- for (i = 1; i < command_lenght; i++) checksum += raw_buf[i];
+ for (i = 1; i < command_length; i++) checksum += raw_buf[i];
checksum = checksum % 256;
- raw_buf[command_lenght] = (unsigned char)checksum;
- command_lenght +=1;
+ raw_buf[command_length] = (unsigned char)checksum;
+ command_length +=1;
retry = 0;
sent = 0;
- while ((sent != (command_lenght)) && (retry < 5)) {
+ while ((sent != (command_length)) && (retry < 5)) {
if (retry == 4) send_zeros(); /* last retry is preceded by a serial reset... */
- sent = ser_send_buf(upsfd, raw_buf, (command_lenght));
- if (sent != (command_lenght)) printf("Error sending command %d\n", raw_buf[2]);
+ sent = ser_send_buf(upsfd, raw_buf, (command_length));
+ if (sent != (command_length)) printf("Error sending command %d\n", raw_buf[2]);
retry += 1;
}
@@ -165,6 +165,6 @@
/* get the answer of a command from the ups */
int get_answer(unsigned char *data) {
- unsigned char my_buf[255]; /* packet has a maximum lenght of 256 bytes */
- int packet_lenght, checksum, i, res;
+ unsigned char my_buf[255]; /* packet has a maximum length of 256 bytes */
+ int packet_length, checksum, i, res;
/* Read STX byte */
res = ser_get_char(upsfd, my_buf, 1, 0);
@@ -177,41 +177,41 @@
return -1;
}
- /* Read data lenght byte */
+ /* Read data length byte */
res = ser_get_char(upsfd, my_buf, 1, 0);
if (res < 1) {
- ser_comm_fail("Receive error (lenght): %d!!!\n", res);
+ ser_comm_fail("Receive error (length): %d!!!\n", res);
return -1;
}
- packet_lenght = my_buf[0];
- if (packet_lenght < 2) {
- ser_comm_fail("Receive error (lenght): packet lenght %d!!!\n", packet_lenght);
+ packet_length = my_buf[0];
+ if (packet_length < 2) {
+ ser_comm_fail("Receive error (length): packet length %d!!!\n", packet_length);
return -1;
}
- /* Try to read all the remainig bytes (packet_lenght) */
- res = ser_get_buf_len(upsfd, my_buf, packet_lenght, 1, 0);
- if (res != packet_lenght) {
- ser_comm_fail("Receive error (data): got %d bytes instead of %d!!!\n", res, packet_lenght);
+ /* Try to read all the remainig bytes (packet_length) */
+ res = ser_get_buf_len(upsfd, my_buf, packet_length, 1, 0);
+ if (res != packet_length) {
+ ser_comm_fail("Receive error (data): got %d bytes instead of %d!!!\n", res, packet_length);
return -1;
}
/* now we have the whole answer from the ups, we can checksum it
- checksum byte is equal to the sum modulus 256 of all the data bytes + packet_lenght
+ checksum byte is equal to the sum modulus 256 of all the data bytes + packet_length
(no STX no checksum byte itself) */
- checksum = packet_lenght;
- for (i = 0; i < (packet_lenght - 1); i++) checksum += my_buf[i];
+ checksum = packet_length;
+ for (i = 0; i < (packet_length - 1); i++) checksum += my_buf[i];
checksum = checksum % 256;
- if (my_buf[packet_lenght-1] != checksum) {
- ser_comm_fail("checksum error! got %x instad of %x, received %d bytes \n", my_buf[packet_lenght - 1], checksum, packet_lenght);
- dump_buffer(my_buf, packet_lenght);
+ if (my_buf[packet_length-1] != checksum) {
+ ser_comm_fail("checksum error! got %x instad of %x, received %d bytes \n", my_buf[packet_length - 1], checksum, packet_length);
+ dump_buffer(my_buf, packet_length);
return -1;
}
- packet_lenght-=1; /* get rid of the checksum byte */
- memcpy(data, my_buf, packet_lenght);
- return packet_lenght;
+ packet_length-=1; /* get rid of the checksum byte */
+ memcpy(data, my_buf, packet_length);
+ return packet_length;
}
/* send a read command and try get the answer, if something fails, it retries (5 times max)
if it is on the 4th or 5th retry, it will flush the serial before sending commands
- it returns the lenght of the received answer or -1 in case of failure */
+ it returns the length of the received answer or -1 in case of failure */
int command_read_sequence(unsigned char command, unsigned char *data) {
int bytes_read = 0;
@@ -235,11 +235,11 @@
/* send a write command and try get the answer, if something fails, it retries (5 times max)
if it is on the 4th or 5th retry, it will flush the serial before sending commands
- it returns the lenght of the received answer or -1 in case of failure */
-int command_write_sequence(unsigned char *command, int command_lenght, unsigned char *answer) {
+ it returns the length of the received answer or -1 in case of failure */
+int command_write_sequence(unsigned char *command, int command_length, unsigned char *answer) {
int bytes_read = 0;
int retry = 0;
while ((bytes_read < 1) && (retry < 5)) {
- send_write_command(command, command_lenght);
+ send_write_command(command, command_length);
bytes_read = get_answer(answer);
if (retry > 2) ser_flush_in(upsfd, "", 0);

View File

@ -1,22 +0,0 @@
diff --git a/drivers/libhid.c b/drivers/libhid.c
index 9387657..f2e8fbb 100644
--- a/drivers/libhid.c
+++ b/drivers/libhid.c
@@ -141,7 +141,7 @@ static int refresh_report_buffer(reportbuf_t *rbuf, hid_dev_handle_t udev, HIDDa
{
int id = pData->ReportID;
int r;
- unsigned char buf[SMALLBUF];
+ unsigned char buf[8];
if (rbuf->ts[id] + age > time(NULL)) {
/* buffered report is still good; nothing to do */
@@ -469,7 +469,7 @@ bool_t HIDSetItemValue(hid_dev_handle_t udev, const char *hidpath, double Value,
*/
int HIDGetEvents(hid_dev_handle_t udev, HIDData_t **event, int eventsize)
{
- unsigned char buf[SMALLBUF];
+ unsigned char buf[8];
int itemCount = 0;
int buflen, r, i;
HIDData_t *pData;

View File

@ -1,14 +0,0 @@
--- a/scripts/udev/nut-usbups.rules.in
+++ b/scripts/udev/nut-usbups.rules.in
@@ -1,9 +1,9 @@
# This file is generated and installed by the Network UPS Tools package.
-ACTION!="add", GOTO="nut-usbups_rules_end"
+ACTION!="add|change", GOTO="nut-usbups_rules_end"
SUBSYSTEM=="usb_device", GOTO="nut-usbups_rules_real"
SUBSYSTEM=="usb", GOTO="nut-usbups_rules_real"
-BUS!="usb", GOTO="nut-usbups_rules_end"
+SUBSYSTEM!="usb", GOTO="nut-usbups_rules_end"
LABEL="nut-usbups_rules_real"
# Krauler UP-M500VA - blazer_usb

View File

@ -1,275 +0,0 @@
--- a/man/powercom.8
+++ b/man/powercom.8
@@ -46,53 +46,53 @@
loadPercentage and validationSequence.
.IP "numOfBytesFromUPS=\fIvalue\fR"
-The number of bytes in a UPS frame. The default is type dependant and
+The number of bytes in a UPS frame. The default is type dependent and
is given below.
.IP "methodOfFlowControl=\fIname\fR"
The method of serial communication flow control that is engaged by the
-UPS. The default is type dependant and is given below. Acceptable names
+UPS. The default is type dependent and is given below. Acceptable names
are dtr0rts1, dtr1 or no_flow_control.
.IP "shutdownArguments=\fI{{minutes,seconds},whether_minutes_should_be_used}\fR"
The minutes and seconds that the UPS should wait between receiving the
shutdown command and actually shutting off. The other argument should
be set to the character \fIn\fR only when the minutes value should be
-skipped and not sent to the UPS. The default is type dependant and is
+skipped and not sent to the UPS. The default is type dependent and is
given below. The braces and commas are mandatory. Note that there should
be no white space characters.
.IP "voltage=\fI{coefficient1,coefficient2,coefficient3,coefficient4}\fR"
Only for KP625AP, Trust, Egys, BNT-other
A quad that is used convert the raw data to human readable voltage
-reading. The default is type dependant and is given below. Do note that
+reading. The default is type dependent and is given below. Do note that
the braces and commas are mandatory, as well as the lack of white space
characters.
.IP "frequency=\fI{coefficient1,coefficient2}\fR"
Only for KP625AP, Trust, Egys
A pair to convert the raw data to human readable frequency reading. The
-default is type dependant and is given below. Do note that the braces
+default is type dependent and is given below. Do note that the braces
and commas are mandatory as well, as the lack of white space characters.
.IP "batteryPercentage=\fI{coefficient1,coefficient2,coefficient3,coefficient4,coefficient5}\fR"
Only for KP625AP, Trust, Egys, BNT-other
A 5 tuple to convert the raw data to human readable battery percentage
-reading. The default is type dependant and is given below. Do note that
+reading. The default is type dependent and is given below. Do note that
the braces and commas are mandatory, as the lack of white space
characters.
.IP "loadPercentage=\fI{coefficient1,coefficient2,coefficient3,coefficient4}\fR"
Only for KP625AP, Trust, Egys, BNT-other
A quad to convert the raw data to human readable load percentage
-reading. The default is type dependant and is given below. Do note that
+reading. The default is type dependent and is given below. Do note that
the braces and commas are mandatory, as the lack of white space
characters.
.IP "validationSequence=\fI{{index1,value1},{index2,value2},{index3,value3}}\fR"
Only for KP625AP, Trust, Egys, BNT-other
3 pairs to be used for validating the UPS by comparing bytes of the raw
-data with constant values. The default is type dependant and is given
+data with constant values. The default is type dependent and is given
below. The braces and commas are mandatory, as the lack of white space
characters.
@@ -105,7 +105,7 @@
.P
The rest of the default values for the extra arguments are type
-dependant:
+dependent:
.IP "Trust"
.RS
--- a/man/upsc.8
+++ b/man/upsc.8
@@ -50,7 +50,7 @@
To list the UPSes configured on this system, along with their descriptions:
.nf
- $ upsc -L
+ $ upsc \-L
apc: Back-UPS 500
ppro2: Patriot Pro II
.fi
@@ -59,7 +59,7 @@
syntax:
.nf
- $ for UPS in `upsc -l mybox:1234`; do
+ $ for UPS in `upsc \-l mybox:1234`; do
upsc $UPS ups.status
done
.fi
--- a/drivers/dummy-ups.c
+++ b/drivers/dummy-ups.c
@@ -337,7 +337,7 @@
/* FIXME: we need to have the full data set before
* enforcing controls! */
- upsdebugx(1, "Unknown data. Commiting anyway...");
+ upsdebugx(1, "Unknown data. Committing anyway...");
return 1;
/* return 0;*/
}
@@ -355,7 +355,7 @@
/* FIXME: we need to have the full data set before
* enforcing controls! */
- upsdebugx(1, "Unknown data. Commiting value anyway...");
+ upsdebugx(1, "Unknown data. Committing value anyway...");
return 1;
/* return 0;*/
}
--- a/drivers/genericups.c
+++ b/drivers/genericups.c
@@ -142,12 +142,12 @@
*/
if ((v = getval("OL")) != NULL) {
parse_input_signals(v, &upstab[upstype].line_ol, &upstab[upstype].val_ol);
- upsdebugx(2, "parse_input_signals: OL overriden with %s\n", v);
+ upsdebugx(2, "parse_input_signals: OL overridden with %s\n", v);
}
if ((v = getval("LB")) != NULL) {
parse_input_signals(v, &upstab[upstype].line_bl, &upstab[upstype].val_bl);
- upsdebugx(2, "parse_input_signals: LB overriden with %s\n", v);
+ upsdebugx(2, "parse_input_signals: LB overridden with %s\n", v);
}
}
@@ -318,12 +318,12 @@
*/
if ((v = getval("CP")) != NULL) {
parse_output_signals(v, &upstab[upstype].line_norm);
- upsdebugx(2, "parse_output_signals: CP overriden with %s\n", v);
+ upsdebugx(2, "parse_output_signals: CP overridden with %s\n", v);
}
if ((v = getval("SD")) != NULL) {
parse_output_signals(v, &upstab[upstype].line_sd);
- upsdebugx(2, "parse_output_signals: SD overriden with %s\n", v);
+ upsdebugx(2, "parse_output_signals: SD overridden with %s\n", v);
}
if (ioctl(upsfd, TIOCMSET, &upstab[upstype].line_norm)) {
--- a/man/upscode2.8
+++ b/man/upscode2.8
@@ -49,7 +49,7 @@
The driver supports the following commands for those UPSen that support them.
The available commands are autodetected during initialization,
-so you should check availability with \fIupscmd -l\fR.
+so you should check availability with \fIupscmd \-l\fR.
test.panel.start \(hy Start UPS self test
--- a/man/usbhid-ups.8
+++ b/man/usbhid-ups.8
@@ -59,7 +59,7 @@
than offdelay, but the driver will \fBnot\fR warn you upon startup if it
isn't. Some UPS'es will restart no matter what, even if the power is
(still) out at the moment this timer elapses. In that case, you could try
-if setting 'ondelay = -1' in \fBups.conf\fR helps.
+if setting 'ondelay = \-1' in \fBups.conf\fR helps.
.IP "pollfreq=\fInum\fR"
Set polling frequency, in seconds, to reduce the USB data flow.
@@ -148,7 +148,7 @@
.nf
usb 2-1: control timeout on ep0in
usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd usbhid-ups rqt 128 rq 6 len 256
- ret -110
+ ret \-110
.fi
In this case, simply modify the general parameter "pollinterval" to a higher
@@ -170,7 +170,7 @@
If you rely on the UPS to shutdown your systems in case of mains failure
and to restart them when the power returns, you \fBmust\fR test this. You
-can do so by running 'upsmon -c fsd'. With the mains present, this should
+can do so by running 'upsmon \-c fsd'. With the mains present, this should
bring your systems down and then cycle the power to restart them again.
If you do the same without mains present, it should do the same, but in
this case, the outputs shall remain off until mains power is applied
--- a/drivers/metasys.c
+++ b/drivers/metasys.c
@@ -179,12 +179,12 @@
/* Read data lenght byte */
res = ser_get_char(upsfd, my_buf, 1, 0);
if (res < 1) {
- ser_comm_fail("Receive error (lenght): %d!!!\n", res);
+ ser_comm_fail("Receive error (length): %d!!!\n", res);
return -1;
}
packet_lenght = my_buf[0];
if (packet_lenght < 2) {
- ser_comm_fail("Receive error (lenght): packet lenght %d!!!\n", packet_lenght);
+ ser_comm_fail("Receive error (length): packet length %d!!!\n", packet_lenght);
return -1;
}
/* Try to read all the remainig bytes (packet_lenght) */
--- a/drivers/snmp-ups.c
+++ b/drivers/snmp-ups.c
@@ -380,7 +380,7 @@
len = snprintf(buf, buf_len, "%ld", *pdu->variables->val.integer / 100);
break;
default:
- upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x recieved from %s",
+ upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x received from %s",
upsname?upsname:device_name, pdu->variables->type, OID);
return FALSE;
break;
@@ -420,7 +420,7 @@
value = *pdu->variables->val.integer / 100;
break;
default:
- upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x recieved from %s",
+ upslogx(LOG_ERR, "[%s] unhandled ASN 0x%x received from %s",
upsname?upsname:device_name, pdu->variables->type, OID);
return FALSE;
break;
@@ -1319,7 +1319,7 @@
if (ret == FALSE)
upslogx(LOG_ERR, "su_setvar: cannot set value %s for %s", arg[4], arg[3]);
else
- upsdebugx(1, "su_setvar: sucessfully set %s to \"%s\"", arg[0], arg[4]);
+ upsdebugx(1, "su_setvar: successfully set %s to \"%s\"", arg[0], arg[4]);
return 1;
}
--- a/man/dummy-ups.8
+++ b/man/dummy-ups.8
@@ -38,7 +38,7 @@
This file is generally named something.dev. It contains a list of all
valid data and associated values, and has the same format as an upsc
-dump (<varname>: <value>). So you can easilly create definition
+dump (<varname>: <value>). So you can easily create definition
files from an existing UPS using "upsc > file.dev".
It can also be empty, in which case only a basic set of data is available:
device.*, driver.*, ups.mfr, ups.model, ups.status
--- a/man/genericups.8
+++ b/man/genericups.8
@@ -235,7 +235,7 @@
Alternatively, you can run genericups in debug mode \(hy
- genericups -DDDDD \-x upstype=n /dev/port
+ genericups \-DDDDD \-x upstype=n /dev/port
In this mode it will be running in the foreground and continuously
display the line and battery status of the UPS.
--- a/man/metasys.8
+++ b/man/metasys.8
@@ -30,7 +30,7 @@
.SH BUGS
This driver has been tested on Meta System HF Millennium 820 and
ally HF 1000 only.
-Any informations about the use of the driver with the other listed
+Any information about the use of the driver with the other listed
ups are really welcome.
.SH AUTHOR
--- a/drivers/apcsmart.c
+++ b/drivers/apcsmart.c
@@ -323,7 +323,7 @@
/* This should never happen since we only call
this if the REQ_CAPABILITIES command is supported
*/
- upslogx(LOG_ERR, "ERROR: APC cannot do capabilites but said it could!");
+ upslogx(LOG_ERR, "ERROR: APC cannot do capabilities but said it could!");
return;
}

View File

@ -1,3 +1 @@
0001-low_speed_usb_ups.patch
0002-fix_udev_action.patch
0003-fix_spelling_and_typo.patch
0001-fix_spelling_and_typo.patch