Add nut-monitor package
This commit is contained in:
parent
14ffb4d76b
commit
63f12aa09f
1
debian/changelog
vendored
1
debian/changelog
vendored
|
@ -12,6 +12,7 @@ nut (2.6.1-2) UNRELEASED; urgency=low
|
|||
* debian/control:
|
||||
- Add python-nut package and add python build-dependency
|
||||
- Set nut-powerman-pdu priority to extras
|
||||
- Add nut-monitor package
|
||||
|
||||
-- Laurent Bigonville <bigon@debian.org> Mon, 27 Jun 2011 17:26:59 +0200
|
||||
|
||||
|
|
17
debian/control
vendored
17
debian/control
vendored
|
@ -166,3 +166,20 @@ Description: network UPS tools - Python bindings for NUT server
|
|||
changes.
|
||||
.
|
||||
This package provides Python bindings to connect to NUT server.
|
||||
|
||||
Package: nut-monitor
|
||||
Architecture: all
|
||||
Depends: ${python:Depends},
|
||||
${misc:Depends},
|
||||
python-gobject,
|
||||
python-gtk2,
|
||||
python-glade2,
|
||||
python-nut
|
||||
Description: network UPS tools - GUI application to monitor UPS status
|
||||
Network UPS Tools (NUT) is a client/server monitoring system that
|
||||
allows computers to share uninterruptible power supply (UPS) and
|
||||
power distribution unit (PDU) hardware. Clients access the hardware
|
||||
through the server, and are notified whenever the power status
|
||||
changes.
|
||||
.
|
||||
This package provides nut-monitor, a GUI application to monitor UPS status.
|
||||
|
|
6
debian/nut-monitor.install
vendored
Normal file
6
debian/nut-monitor.install
vendored
Normal file
|
@ -0,0 +1,6 @@
|
|||
scripts/python/app/NUT-Monitor usr/bin/
|
||||
scripts/python/app/nut-monitor.desktop usr/share/applications/
|
||||
scripts/python/app/gui-*.glade usr/share/nut-monitor/
|
||||
scripts/python/app/locale/ usr/share/
|
||||
scripts/python/app/nut-monitor.png usr/share/pixmaps/
|
||||
scripts/python/app/pixmaps usr/share/nut-monitor/
|
48
debian/patches/0002-nut-monitor-paths.patch
vendored
Normal file
48
debian/patches/0002-nut-monitor-paths.patch
vendored
Normal file
|
@ -0,0 +1,48 @@
|
|||
--- a/scripts/python/app/NUT-Monitor
|
||||
+++ b/scripts/python/app/NUT-Monitor
|
||||
@@ -70,7 +70,7 @@
|
||||
( cmd_opts, args ) = opt_parser.parse_args()
|
||||
|
||||
|
||||
- self.__glade_file = os.path.join( os.path.dirname( sys.argv[0] ), "gui-1.3.glade" )
|
||||
+ self.__glade_file = '/usr/share/nut-monitor/gui-1.3.glade'
|
||||
|
||||
self.__widgets["interface"] = gtk.glade.XML( self.__glade_file, "window1", APP )
|
||||
self.__widgets["main_window"] = self.__widgets["interface"].get_widget("window1")
|
||||
@@ -103,11 +103,11 @@
|
||||
|
||||
# Create the tray icon and connect it to the show/hide method...
|
||||
self.__widgets["status_icon"] = gtk.StatusIcon()
|
||||
- self.__widgets["status_icon"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "on_line.png" ) )
|
||||
+ self.__widgets["status_icon"].set_from_file( "/usr/share/nut-monitor/pixmaps/on_line.png" )
|
||||
self.__widgets["status_icon"].set_visible( True )
|
||||
self.__widgets["status_icon"].connect( "activate", self.tray_activated )
|
||||
|
||||
- self.__widgets["ups_status_image"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "on_line.png" ) )
|
||||
+ self.__widgets["ups_status_image"].set_from_file( "/usr/share/nut-monitor/pixmaps/on_line.png" )
|
||||
|
||||
# Define interface callbacks actions
|
||||
self.__callbacks = { "on_window1_destroy" : self.quit,
|
||||
@@ -265,8 +265,8 @@
|
||||
#-------------------------------------------------------------------
|
||||
# Change the status icon and tray icon
|
||||
def change_status_icon( self, icon="on_line", blink=False ) :
|
||||
- self.__widgets["status_icon"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "%s.png" % icon ) )
|
||||
- self.__widgets["ups_status_image"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "%s.png" % icon ) )
|
||||
+ self.__widgets["status_icon"].set_from_file( "/usr/share/nut-monitor/pixmaps/%s.png" % icon )
|
||||
+ self.__widgets["ups_status_image"].set_from_file( "/usr/share/nut-monitor/pixmaps/%s.png" % icon )
|
||||
self.__widgets["status_icon"].set_blinking( blink )
|
||||
|
||||
#-------------------------------------------------------------------
|
||||
@@ -719,9 +719,9 @@
|
||||
|
||||
for k,v in vars.iteritems() :
|
||||
if ( rwvars.has_key( k ) ) :
|
||||
- icon_file = os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "var-rw.png" )
|
||||
+ icon_file = "/usr/share/nut-monitor/pixmaps/var-rw.png"
|
||||
else :
|
||||
- icon_file = os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "var-ro.png" )
|
||||
+ icon_file = "/usr/share/nut-monitor/pixmaps/var-ro.png"
|
||||
|
||||
icon = gtk.gdk.pixbuf_new_from_file( icon_file )
|
||||
self.__widgets["ups_vars_tree_store"].append( [ icon, k, v ] )
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1 +1,2 @@
|
|||
0001-fix_spelling_and_typo.patch
|
||||
0002-nut-monitor-paths.patch
|
||||
|
|
3
debian/rules
vendored
3
debian/rules
vendored
|
@ -44,6 +44,9 @@ common-install-arch::
|
|||
mv $${f} $(CURDIR)/debian/tmp/etc/nut/$${nf}; \
|
||||
done
|
||||
|
||||
binary-install/nut-monitor::
|
||||
dh_python2 -pnut-monitor
|
||||
|
||||
DEB_DH_INSTALLINIT_ARGS_nut-server := --init-script=nut -- start 50 2 3 4 5 . stop 50 0 1 6 .
|
||||
|
||||
ifeq (linux,$(DEB_HOST_ARCH_OS))
|
||||
|
|
Loading…
Reference in New Issue
Block a user