debian/patches/0001-low_speed_usb_ups.patch: Use patch system for changes that were applied directly in the source
This commit is contained in:
parent
d71a946e56
commit
2f40c02cd5
4
debian/changelog
vendored
4
debian/changelog
vendored
|
@ -4,8 +4,10 @@ nut (2.4.3-2) UNRELEASED; urgency=low
|
|||
- Bump Standards-Version to 3.9.1
|
||||
- Update Vcs-* fields to new GIT repository
|
||||
* Switch to dpkg-source 3.0 (quilt) format (Closes: #573601)
|
||||
* debian/patches/0001-low_speed_usb_ups.patch: Use patch system for changes
|
||||
that were applied directly in the source
|
||||
|
||||
-- Laurent Bigonville <bigon@debian.org> Tue, 21 Dec 2010 14:42:34 +0100
|
||||
-- Laurent Bigonville <bigon@debian.org> Tue, 21 Dec 2010 14:50:09 +0100
|
||||
|
||||
nut (2.4.3-1.1) unstable; urgency=low
|
||||
|
||||
|
|
22
debian/patches/0001-low_speed_usb_ups.patch
vendored
Normal file
22
debian/patches/0001-low_speed_usb_ups.patch
vendored
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff --git a/drivers/libhid.c b/drivers/libhid.c
|
||||
index 9387657..f2e8fbb 100644
|
||||
--- a/drivers/libhid.c
|
||||
+++ b/drivers/libhid.c
|
||||
@@ -141,7 +141,7 @@ static int refresh_report_buffer(reportbuf_t *rbuf, hid_dev_handle_t udev, HIDDa
|
||||
{
|
||||
int id = pData->ReportID;
|
||||
int r;
|
||||
- unsigned char buf[SMALLBUF];
|
||||
+ unsigned char buf[8];
|
||||
|
||||
if (rbuf->ts[id] + age > time(NULL)) {
|
||||
/* buffered report is still good; nothing to do */
|
||||
@@ -469,7 +469,7 @@ bool_t HIDSetItemValue(hid_dev_handle_t udev, const char *hidpath, double Value,
|
||||
*/
|
||||
int HIDGetEvents(hid_dev_handle_t udev, HIDData_t **event, int eventsize)
|
||||
{
|
||||
- unsigned char buf[SMALLBUF];
|
||||
+ unsigned char buf[8];
|
||||
int itemCount = 0;
|
||||
int buflen, r, i;
|
||||
HIDData_t *pData;
|
1
debian/patches/series
vendored
Normal file
1
debian/patches/series
vendored
Normal file
|
@ -0,0 +1 @@
|
|||
0001-low_speed_usb_ups.patch
|
|
@ -141,7 +141,7 @@ static int refresh_report_buffer(reportbuf_t *rbuf, hid_dev_handle_t udev, HIDDa
|
|||
{
|
||||
int id = pData->ReportID;
|
||||
int r;
|
||||
unsigned char buf[8];
|
||||
unsigned char buf[SMALLBUF];
|
||||
|
||||
if (rbuf->ts[id] + age > time(NULL)) {
|
||||
/* buffered report is still good; nothing to do */
|
||||
|
@ -469,7 +469,7 @@ bool_t HIDSetItemValue(hid_dev_handle_t udev, const char *hidpath, double Value,
|
|||
*/
|
||||
int HIDGetEvents(hid_dev_handle_t udev, HIDData_t **event, int eventsize)
|
||||
{
|
||||
unsigned char buf[8];
|
||||
unsigned char buf[SMALLBUF];
|
||||
int itemCount = 0;
|
||||
int buflen, r, i;
|
||||
HIDData_t *pData;
|
||||
|
|
Loading…
Reference in New Issue
Block a user