Properly install the icons and other UI data for nut-monitor
This commit is contained in:
parent
bbda8c3814
commit
2740456b51
3
debian/changelog
vendored
3
debian/changelog
vendored
|
@ -35,8 +35,9 @@ nut (2.8.0-1) UNRELEASED; urgency=medium
|
||||||
* Install nut-driver-enumerator.sh in /usr/libexec/
|
* Install nut-driver-enumerator.sh in /usr/libexec/
|
||||||
* debian/*.symbols: Add Build-Depends-Package field
|
* debian/*.symbols: Add Build-Depends-Package field
|
||||||
* debian/libnutclient2.symbols: Run through c++filt to make symbols readable
|
* debian/libnutclient2.symbols: Run through c++filt to make symbols readable
|
||||||
|
* Properly install the icons and other UI data for nut-monitor
|
||||||
|
|
||||||
-- Laurent Bigonville <bigon@debian.org> Sun, 10 Jul 2022 12:48:56 +0200
|
-- Laurent Bigonville <bigon@debian.org> Sun, 10 Jul 2022 20:06:27 +0200
|
||||||
|
|
||||||
nut (2.7.4-14) unstable; urgency=medium
|
nut (2.7.4-14) unstable; urgency=medium
|
||||||
|
|
||||||
|
|
8
debian/nut-monitor.install
vendored
8
debian/nut-monitor.install
vendored
|
@ -1,6 +1,10 @@
|
||||||
scripts/python/app/NUT-Monitor-py3qt5 usr/bin/
|
scripts/python/app/NUT-Monitor-py3qt5 usr/bin/
|
||||||
scripts/python/app/locale/ usr/share/
|
scripts/python/app/locale/ usr/share/
|
||||||
scripts/python/app/icons/ usr/share/icons/hicolor/
|
scripts/python/app/icons/256x256/nut-monitor.png usr/share/icons/hicolor/256x256/apps/
|
||||||
scripts/python/app/pixmaps usr/share/nut-monitor/
|
scripts/python/app/icons/48x48/nut-monitor.png usr/share/icons/hicolor/48x48/apps/
|
||||||
|
scripts/python/app/icons/64x64/nut-monitor.png usr/share/icons/hicolor/64x64/apps/
|
||||||
|
scripts/python/app/icons/scalable/nut-monitor.svg usr/share/icons/hicolor/scalable/apps/
|
||||||
|
scripts/python/app/pixmaps usr/share/NUT-Monitor-py3qt5/
|
||||||
|
scripts/python/app/ui/ usr/share/NUT-Monitor-py3qt5/
|
||||||
scripts/python/app/nut-monitor.appdata.xml usr/share/metainfo/
|
scripts/python/app/nut-monitor.appdata.xml usr/share/metainfo/
|
||||||
scripts/python/app/nut-monitor-py3qt5.desktop usr/share/applications/
|
scripts/python/app/nut-monitor-py3qt5.desktop usr/share/applications/
|
||||||
|
|
2
debian/nut-monitor.links
vendored
2
debian/nut-monitor.links
vendored
|
@ -1 +1,3 @@
|
||||||
usr/bin/NUT-Monitor-py3qt5 usr/bin/NUT-Monitor
|
usr/bin/NUT-Monitor-py3qt5 usr/bin/NUT-Monitor
|
||||||
|
usr/share/NUT-Monitor-py3qt5/ usr/share/NUT-Monitor
|
||||||
|
usr/share/icons/hicolor/256x256/apps/nut-monitor.png usr/share/NUT-Monitor-py3qt5/icons/hicolor/256x256/apps/nut-monitor.png
|
||||||
|
|
48
debian/patches/0002-nut-monitor-paths.patch
vendored
48
debian/patches/0002-nut-monitor-paths.patch
vendored
|
@ -1,48 +0,0 @@
|
||||||
--- a/scripts/python/app/NUT-Monitor
|
|
||||||
+++ b/scripts/python/app/NUT-Monitor
|
|
||||||
@@ -76,7 +76,7 @@ class interface :
|
|
||||||
( cmd_opts, args ) = opt_parser.parse_args()
|
|
||||||
|
|
||||||
|
|
||||||
- self.__glade_file = os.path.join( os.path.dirname( sys.argv[0] ), "gui-1.3.glade" )
|
|
||||||
+ self.__glade_file = '/usr/share/nut-monitor/gui-1.3.glade'
|
|
||||||
|
|
||||||
self.__widgets["interface"] = gtk.glade.XML( self.__glade_file, "window1", APP )
|
|
||||||
self.__widgets["main_window"] = self.__widgets["interface"].get_widget("window1")
|
|
||||||
@@ -109,11 +109,11 @@ class interface :
|
|
||||||
|
|
||||||
# Create the tray icon and connect it to the show/hide method...
|
|
||||||
self.__widgets["status_icon"] = gtk.StatusIcon()
|
|
||||||
- self.__widgets["status_icon"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "on_line.png" ) )
|
|
||||||
+ self.__widgets["status_icon"].set_from_file( "/usr/share/nut-monitor/pixmaps/on_line.png" )
|
|
||||||
self.__widgets["status_icon"].set_visible( True )
|
|
||||||
self.__widgets["status_icon"].connect( "activate", self.tray_activated )
|
|
||||||
|
|
||||||
- self.__widgets["ups_status_image"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "on_line.png" ) )
|
|
||||||
+ self.__widgets["ups_status_image"].set_from_file( "/usr/share/nut-monitor/pixmaps/on_line.png" )
|
|
||||||
|
|
||||||
# Define interface callbacks actions
|
|
||||||
self.__callbacks = { "on_window1_destroy" : self.quit,
|
|
||||||
@@ -271,8 +271,8 @@ class interface :
|
|
||||||
#-------------------------------------------------------------------
|
|
||||||
# Change the status icon and tray icon
|
|
||||||
def change_status_icon( self, icon="on_line", blink=False ) :
|
|
||||||
- self.__widgets["status_icon"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "%s.png" % icon ) )
|
|
||||||
- self.__widgets["ups_status_image"].set_from_file( os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "%s.png" % icon ) )
|
|
||||||
+ self.__widgets["status_icon"].set_from_file( "/usr/share/nut-monitor/pixmaps/%s.png" % icon )
|
|
||||||
+ self.__widgets["ups_status_image"].set_from_file( "/usr/share/nut-monitor/pixmaps/%s.png" % icon )
|
|
||||||
self.__widgets["status_icon"].set_blinking( blink )
|
|
||||||
|
|
||||||
#-------------------------------------------------------------------
|
|
||||||
@@ -728,9 +728,9 @@ class interface :
|
|
||||||
|
|
||||||
for k,v in vars.iteritems() :
|
|
||||||
if ( rwvars.has_key( k ) ) :
|
|
||||||
- icon_file = os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "var-rw.png" )
|
|
||||||
+ icon_file = "/usr/share/nut-monitor/pixmaps/var-rw.png"
|
|
||||||
else :
|
|
||||||
- icon_file = os.path.join( os.path.dirname( sys.argv[0] ), "pixmaps", "var-ro.png" )
|
|
||||||
+ icon_file = "/usr/share/nut-monitor/pixmaps/var-ro.png"
|
|
||||||
|
|
||||||
icon = gtk.gdk.pixbuf_new_from_file( icon_file )
|
|
||||||
self.__widgets["ups_vars_tree_store"].append( [ icon, k, v ] )
|
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1,6 +1,5 @@
|
||||||
0001-reproductible-build.patch
|
0001-reproductible-build.patch
|
||||||
0003-install-dev-files-in-usr.patch
|
0003-install-dev-files-in-usr.patch
|
||||||
#0002-nut-monitor-paths.patch
|
|
||||||
0008-drop-w3c-icons.patch
|
0008-drop-w3c-icons.patch
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
|
|
Loading…
Reference in New Issue
Block a user